The disable-connected-check was created exactly for the aim of peering two instantly related routers on their loopbacks with out utilizing the ebgp-multihop.
BGP Disable-Related-Examine
By default there are two precautions when establishing eBGP neighborships:
- Examine whether or not the shopper is on a instantly related community. If it isn’t, there received’t be any try and type the neighborship. This examine might be deactivated on a per-neighbor foundation utilizing the neighbor disable-connected-check
- The default TTL worth for the packets carrying the BGP messages is 1 except we configure ebgp-multihop to switch the TTL worth. If the ebgp-multihop is configured, the router routinely and implicitly behaves to the neighbor as if the disable-connected-check was configured. In different phrases, utilizing ebgp-multihop routinely implies disable-connected-check
Associated- Troubleshooting not directly related eBGP neighbors
Disable-connected-check just isn’t used once we use both TTL-security or eBGP multihop with a numerical argument of two or higher hops. In these circumstances, it routinely will get activated and doesn’t require particular configurations. That is configured below the router BGP course of together with the neighbor assertion.
Associated- TTL Safety in BGP
Beneath state of affairs will assist perceive the idea of “Disable-Related-Examine” in a extra detailed means –
Instance State of affairs
The gadgets R1 and R2 are organized as per the above-shown diagram.
Configuration
R1:
interface Loopback0
ip handle 1.1.1.1 255.255.255.255
!
interface FastEthernet0/0
ip handle 9.9.12.1 255.255.255.0
!
router bgp 100
bgp log-neighbor-changes
neighbor 2.2.2.2 remote-as 200
neighbor 2.2.2.2 disable-connected-check
neighbor 2.2.2.2 update-source Loopback0
!
ip route 2.2.2.2 255.255.255.255 9.9.12.2
R2:
interface Loopback0
ip handle 2.2.2.2 255.255.255.255
!
interface FastEthernet0/0
ip handle 9.9.12.2 255.255.255.0
!
router bgp 200
bgp log-neighbor-changes
neighbor 1.1.1.1 remote-as 100
neighbor 1.1.1.1 disable-connected-check
neighbor 1.1.1.1 update-source Loopback0
!
ip route 1.1.1.1 255.255.255.255 9.9.12.1
Verification
R1#sh ip bgp abstract
BGP desk model is 1, most important routing desk model 1
Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
2.2.2.2 4 200 7 7 1 0 0 00:02:57 0
R1#
As proven above , neighborship over Loopbacks is being fashioned with out want of “eBGP Multihop” configuration requirement .
Associated- BGP Multipath State of affairs