Friday, April 21, 2023
HomeNetworkingPerceive and Configure BGP Desk-Map

Perceive and Configure BGP Desk-Map


There are numerous conditions the place you’d need to optimize the efficiency of your route-reflector in BGP community. By default BGP downloads all of the routes in RIB. BGP Desk-Map is likely one of the strategies to attain BGP selective route obtain significantly used on the Route-Reflectors.

Understanding BGP Desk-Map

BGP Desk-map is main used to suppress the pointless downloading of sure BGP routes to the RIB or Forwarding Info Base (FIB) on a devoted route reflector, which propagates BGP updates with out carrying transit visitors.

Suppressing/Filtering the routes in RIB/FIB on the devoted route-reflectors offers important saving on the reminiscence and CPU sources on the router.

Notice that the Selective Route Obtain characteristic shouldn’t be relevant to Multiprotocol Label Switching (MPLS) Layer 3 VPN as a result of the route obtain is already robotically suppressed on a route reflector.

The table-map command is configured beneath route BGP course of and is utilized on the router as a complete and never on per neighbor foundation as route-maps.

It is very important perceive the usage of the filter key phrase within the BGP table-map command:

  • When the table-map command is used with out the filter key phrase, the route map referenced within the table-map command is used to set sure properties (such because the visitors index) of the routes for set up into the RIB. The route is at all times downloaded, no matter whether or not it’s permitted or denied by the route map.
  • When the table-map command is used with the filter key phrase, the route map referenced can also be used to manage whether or not a BGP route is to be downloaded to the RIB (therefore the filter). A BGP route shouldn’t be downloaded to the RIB whether it is denied by the route map.

We are able to create a route-map to allow or deny the routes to be downloaded within the RIB or FIB after which use this route-map with the table-map command.

Associated- BGP Suppress MAP and Attribute MAP

Instance Situation: Use of BGP Desk-Map

Let’s use the under topology to grasp the usage of BGP Desk-Map

understand-and-configure-bgp-table-map

Within the topology diagram above R1 is promoting a route of its loopback 1 i.e. 1.1.1.1 to Route-Reflector. We’ve utilized a route-map on Route-Reflector to disclaim every little thing after which this route-map is known as within the table-map command so keep away from the set up of the route within the RIB and FIB on the RR.

Although RR doesn’t set up the route in its RIB & FIB it nonetheless displays the path to R2.

Configuration:

R1:

interface Loopback0ip tackle 9.9.0.1 255.255.255.255

ip ospf 1 space 0

!

interface Loopback1

ip tackle 1.1.1.1 255.255.255.255

!

interface FastEthernet0/0

ip tackle 9.9.13.1 255.255.255.0

ip ospf 1 space 0

!

router bgp 100

community 1.1.1.1 masks 255.255.255.255

neighbor 9.9.0.3 remote-as 100

neighbor 9.9.0.3 update-source Loopback0

R2:

interface Loopback0ip tackle 9.9.0.2 255.255.255.255

ip ospf 1 space 0

!

interface FastEthernet0/0

ip tackle 9.9.23.2 255.255.255.0

ip ospf 1 space 0

!

router bgp 100

neighbor 9.9.0.3 remote-as 100

neighbor 9.9.0.3 update-source Loopback0

R3:

interface Loopback0ip tackle 9.9.0.3 255.255.255.255

ip ospf 1 space 0

!

interface FastEthernet0/0

ip tackle 9.9.13.3 255.255.255.0

ip ospf 1 space 0

!

interface FastEthernet1/0

ip tackle 9.9.23.3 255.255.255.0

ip ospf 1 space 0

l!

router bgp 100

table-map tmap filter

bgp log-neighbor-changes

neighbor 9.9.0.1 remote-as 100

neighbor 9.9.0.1 update-source Loopback0

neighbor 9.9.0.1 route-reflector-client

neighbor 9.9.0.2 remote-as 100

neighbor 9.9.0.2 update-source Loopback0

neighbor 9.9.0.2 route-reflector-client

!

route-map tmap deny 10

Check Outcomes:

Situation 1: Desk-Map isn’t utilized 

As of now we’re in a position to see the route of 1.1.1.1 on R3 in RIB and FIB.

R3#sh ip route

Codes: L – native, C – linked, S – static, R – RIP, M – cell, B – BGP

       D – EIGRP, EX – EIGRP exterior, O – OSPF, IA – OSPF inter space

       N1 – OSPF NSSA exterior kind 1, N2 – OSPF NSSA exterior kind 2

       E1 – OSPF exterior kind 1, E2 – OSPF exterior kind 2

       i – IS-IS, su – IS-IS abstract, L1 – IS-IS level-1, L2 – IS-IS level-2

       ia – IS-IS inter space, * – candidate default, U – per-user static route

       o – ODR, P – periodic downloaded static route, H – NHRP, l – LISP

       + – replicated route, % – subsequent hop override

Gateway of final resort shouldn’t be set 

     1.0.0.0/32 is subnetted, 1 subnets

B       1.1.1.1 [200/0] by way of 9.9.0.1, 00:00:05

   9.0.0.0/8 is variably subnetted, 7 subnets, 2 masks

O       9.9.0.1/32 [110/2] by way of 9.9.13.1, 00:13:06, FastEthernet0/0

O       9.9.0.2/32 [110/2] by way of 9.9.23.2, 00:13:06, FastEthernet1/0

C       9.9.0.3/32 is straight linked, Loopback0

C       9.9.13.0/24 is straight linked, FastEthernet0/0

L       9.9.13.3/32 is straight linked, FastEthernet0/0

C       9.9.23.0/24 is straight linked, FastEthernet1/0

L       9.9.23.3/32 is straight linked, FastEthernet1/0

Route for 1.1.1.1 can also be obtained on R2 from R3.

R2#sh ip route 1.1.1.1

Routing entry for 1.1.1.1/32Recognized by way of “bgp 100”, distance 200, metric 0, kind inside

Final replace from 9.9.0.1 00:02:22 in the past

Routing Descriptor Blocks:

* 9.9.0.1, from 9.9.0.3, 00:02:22 in the past

     Route metric is 0, visitors share rely is 1

     AS Hops 0

     MPLS label: none

Situation 2: Desk-Map is utilized beneath router BGP 

Now we’ve configured table-map to disclaim the suppress route for 1.1.1.1 in RIB and FIB.

route-map tmap deny 10!

router bgp 100

table-map tmap filter

R1 sends the path to R3.

R1#sh ip bgp neighbors 9.9.0.3 advertised-routes

BGP desk model is 2, native router ID is 9.9.13.1Standing codes: s suppressed, d damped, h historical past, * legitimate, > greatest, i – inside,

             r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,

             x best-external, a additional-path, c RIB-compressed,

Origin codes: i – IGP, e – EGP, ? – incomplete

RPKI validation codes: V legitimate, I invalid, N Not discovered

     Community         Subsequent Hop            Metric   LocPrf   Weight   Path

*> 1.1.1.1/32       0.0.0.0                 0                             32768    i

Whole variety of prefixes 1

R3 doesn’t set up the route in its RIB & FIB because the route-map tmap is configured to disclaim all of the routes.

Notice that beneath the route-map we are able to permit or deny the routes if required.

R3#sh ip route 1.1.1.1

 R3#sh ip cef 1.1.1.1

0.0.0.0/0no route

 R2 nonetheless will get the route of 1.1.1.1 by way of R3:

R2#sh ip route 1.1.1.1

Routing entry for 1.1.1.1/32Recognized by way of “bgp 100”, distance 200, metric 0, kind inside

Final replace from 9.9.0.1 00:06:01 in the past

Routing Descriptor Blocks:

* 9.9.0.1, from 9.9.0.3, 00:06:01 in the past

     Route metric is 0, visitors share rely is 1

     AS Hops 0

     MPLS label: none

Associated- Non-Exist-Map & BGP Promote-Map

RELATED ARTICLES

LEAVE A REPLY

Please enter your comment!
Please enter your name here

- Advertisment -
Google search engine

Most Popular

Recent Comments