There are two ways in which assist us to mitigate the BGPs full-mesh requirement in a community:
- Utilizing BGP route-reflectors
- Utilizing BGP confederation
What’s BGP Confederation & The way it Works?
On this publish, we are going to perceive how BGP confederation works and also will configure as easy topology explaining tips on how to configure the identical.
BGP confederations permit us to divide a single AS into a number of ASs and assign the entire group to a single AS. Every smaller AS might want to have a full mesh inside its personal AS.
Associated – BGP Interview Questions
Although this ASs could have EBGP friends to ASs inside the confederation, they change routing as in the event that they had been utilizing IBGP; subsequent hop, metric and native desire data is preserved.
To the skin world, the confederation (the group of ASs) will seem like a single AS.
We are going to use the beneath topology to configure the BGP confederation:
- Within the above topology routers R2, R3, R4 & R5 are a part of the identical AS 100.
- We’ve divided AS 100 into two smaller AS 10 and 20 with two routers every.
- R2 & R3 will type an IBGP neighbor ship in AS 10.
- R4 & R5 will type an IBGP neighbor ship in AS 20.
- R3 and R4 will type EBGP neighbor ship.
Associated – BGP Native Choice Cisco
Configuration –
R1:
ip deal with 1.1.1.1 255.255.255.255
!
interface FastEthernet0/0
ip deal with 9.9.12.1 255.255.255.0
!
router bgp 200
bgp log-neighbor-changes
community 1.1.1.1 masks 255.255.255.255
neighbor 9.9.12.2 remote-as 100
R2:
ip deal with 9.9.0.2 255.255.255.255
ip ospf 1 space 0
!
interface FastEthernet0/0
ip deal with 9.9.12.2 255.255.255.0
!
interface FastEthernet1/0
ip deal with 9.9.23.2 255.255.255.0
ip ospf 1 space 0
!
router bgp 10
bgp log-neighbor-changes
bgp confederation identifier 100
bgp confederation friends 20
neighbor 9.9.0.3 remote-as 10
neighbor 9.9.0.3 update-source Loopback0
neighbor 9.9.12.1 remote-as 200
R3:
ip deal with 9.9.0.3 255.255.255.255
ip ospf 1 space 0
!
interface FastEthernet0/0
ip deal with 9.9.23.3 255.255.255.0
ip ospf 1 space 0
!
interface FastEthernet1/0
ip deal with 9.9.34.3 255.255.255.0
ip ospf 1 space 0
!
router bgp 10
bgp log-neighbor-changes
bgp confederation identifier 100
bgp confederation friends 20
neighbor 9.9.0.2 remote-as 10
neighbor 9.9.0.2 update-source Loopback0
neighbor 9.9.0.4 remote-as 20
neighbor 9.9.0.4 ebgp-multihop 2 # Makes use of EBGP multihop as R4 is handled as a EBGP neighbor inside a confederation and Loopback of R4 is one hop away from R3.
neighbor 9.9.0.4 update-source Loopback0
R4:
ip deal with 9.9.0.4 255.255.255.255
ip ospf 1 space 0
!
interface FastEthernet0/0
ip deal with 9.9.34.4 255.255.255.0
ip ospf 1 space 0
!
interface FastEthernet1/0
ip deal with 9.9.45.4 255.255.255.0
ip ospf 1 space 0
!
router bgp 20
bgp log-neighbor-changes
bgp confederation identifier 100
bgp confederation friends 10
neighbor 9.9.0.3 remote-as 10
neighbor 9.9.0.3 ebgp-multihop 2
neighbor 9.9.0.3 update-source Loopback0
neighbor 9.9.0.5 remote-as 20
neighbor 9.9.0.5 update-source Loopback0
R5:
ip deal with 9.9.0.5 255.255.255.255
ip ospf 1 space 0
!
interface FastEthernet0/0
ip deal with 9.9.45.5 255.255.255.0
ip ospf 1 space 0
!
interface FastEthernet1/0
ip deal with 9.9.56.5 255.255.255.0
!
router bgp 20
bgp log-neighbor-changes
bgp confederation identifier 100
bgp confederation friends 10
neighbor 9.9.0.4 remote-as 20
neighbor 9.9.0.4 update-source Loopback0
neighbor 9.9.56.6 remote-as 200
R6:
ip deal with 6.6.6.6 255.255.255.255
!
interface FastEthernet0/0
ip deal with 9.9.56.6 255.255.255.0
!
router bgp 200
bgp log-neighbor-changes
community 6.6.6.6 masks 255.255.255.255
neighbor 9.9.56.5 remote-as 100
Logs
R3 varieties IBGP with R2 and EBGP with R4:
R3#sh ip bgp abstract
BGP desk model is 1, most important routing desk model 1
1 community entries utilizing 144 bytes of reminiscence
1 path entries utilizing 80 bytes of reminiscence
1/0 BGP path/bestpath attribute entries utilizing 136 bytes of reminiscence
1 BGP AS-PATH entries utilizing 24 bytes of reminiscence
0 BGP route-map cache entries utilizing 0 bytes of reminiscence
0 BGP filter-list cache entries utilizing 0 bytes of reminiscence
BGP utilizing 384 whole bytes of reminiscence
BGP exercise 1/0 prefixes, 1/0 paths, scan interval 60 secs
Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
9.9.0.2 4 10 5 4 1 0 0 00:01:15 1
9.9.0.4 4 20 4 4 1 0 0 00:01:07 0
And Equally R4 varieties IBGP with R5 and EBGP with R3:
R4#sh ip bgp abstract
BGP desk model is 1, most important routing desk model 1
1 community entries utilizing 144 bytes of reminiscence
1 path entries utilizing 80 bytes of reminiscence
1/0 BGP path/bestpath attribute entries utilizing 136 bytes of reminiscence
1 BGP AS-PATH entries utilizing 24 bytes of reminiscence
0 BGP route-map cache entries utilizing 0 bytes of reminiscence
0 BGP filter-list cache entries utilizing 0 bytes of reminiscence
BGP utilizing 384 whole bytes of reminiscence
BGP exercise 1/0 prefixes, 1/0 paths, scan interval 60 secs
Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
9.9.0.3 4 10 5 4 1 0 0 00:01:42 0
9.9.0.5 4 20 6 4 1 0 0 00:01:50 1
However for the exterior routers R1 and R6, the distant AS shall be seen as a single AS 100 they usually type neighbor ship with R2 and R5 respectively.
R1#sh ip bgp abstract
BGP desk model is 2, most important routing desk model 2
1 community entries utilizing 144 bytes of reminiscence
1 path entries utilizing 80 bytes of reminiscence
1/1 BGP path/bestpath attribute entries utilizing 136 bytes of reminiscence
0 BGP route-map cache entries utilizing 0 bytes of reminiscence
0 BGP filter-list cache entries utilizing 0 bytes of reminiscence
BGP utilizing 360 whole bytes of reminiscence
BGP exercise 1/0 prefixes, 1/0 paths, scan interval 60 secs
Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
9.9.12.2 4 100 5 7 2 0 0 00:03:02 0
R6#sh ip bgp abstract
BGP desk model is 2, most important routing desk model 2
1 community entries utilizing 144 bytes of reminiscence
1 path entries utilizing 80 bytes of reminiscence
1/1 BGP path/bestpath attribute entries utilizing 136 bytes of reminiscence
0 BGP route-map cache entries utilizing 0 bytes of reminiscence
0 BGP filter-list cache entries utilizing 0 bytes of reminiscence
BGP utilizing 360 whole bytes of reminiscence
BGP exercise 1/0 prefixes, 1/0 paths, scan interval 60 secs
Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
9.9.56.5 4 100 6 7 2 0 0 00:03:09 0
Hope you’d have understood all about BGP Confederation.