Based mostly on the expertise of how BGP behaves, now we have come throughout many topology associated interview questions which we are going to preserve discussing in upcoming posts. One such BGP Situation interview query is predicated on the beneath topology:
BGP Situation
We’ve two routers straight linked in several AS i.e. R1 is in AS 100 and R2 in AS 200.We are able to ping the loopback of R1 from R2 and vice-versa. Now once we attempt to type EBGP neighborship between R1 and R2 it doesn’t come up.
Lab Setup
R1 Â Config
ip handle 9.9.12.1 255.255.255.0
!
interface Loopback0
ip handle 1.1.1.1 255.255.255.255
!
router bgp 100
bgp log-neighbor-changes
neighbor 2.2.2.2 remote-as 200
neighbor 2.2.2.2 update-source Loopback0
neighbor 2.2.2.2 ebgp-multihop 2
!
ip route 0.0.0.0 0.0.0.0 9.9.12.2
R2 Config
ip handle 9.9.12.2 255.255.255.0
!
interface Loopback0
ip handle 2.2.2.2 255.255.255.255
!
router bgp 200
bgp log-neighbor-changes
neighbor 1.1.1.1 remote-as 100
neighbor 1.1.1.1 update-source Loopback0
neighbor 1.1.1.1 remote-as 100
neighbor 1.1.1.1 ebgp-multihop 2
!
ip route 0.0.0.0 0.0.0.0 9.9.12.1
Â
Verification:
Ping from R1 to R2:
Sort escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:
!!!!!
Success price is 100% (5/5), round-trip min/avg/max = 32/45/60 ms
BGP router identifier 2.2.2.2, native AS quantity 200
BGP desk model is 1, foremost routing desk model 1
Neighbor       V   AS  MsgRcvd  MsgSent  TblVer InQ OutQ   Up/Down   State/PfxRcd
1.1.1.1        4         100      0         0        1       0    0       by no means       Idle
We see within the output above that R1 can attain R2’S loopback however nonetheless we will’t type the BGP neighbor ship over the loopback with R2 although we used update-source loopback as properly.
The rationale behind such habits is that now we have reachability of the 2 loopback over the default route. In BGP we want a particular route or a abstract path to the neighbor IP to type the BGP neighbor ship.
Now we see as quickly as we add a particular route on each the routers in direction of there loopback we see the neighbor ship will get fashioned.
R2(config)#ip route 1.1.1.1 255.255.255.255 9.9.12.1
BGP router identifier 1.1.1.1, native AS quantity 100
BGP desk model is 1, foremost routing desk model 1
Neighbor       V  AS   MsgRcvd  MsgSent  TblVer   InQ OutQ   Up/Down     State/PfxRcd
2.2.2.2Â Â Â Â Â Â Â Â 4Â Â Â Â Â 200Â Â Â 5Â Â Â Â Â Â Â Â Â Â 5Â Â Â Â Â Â Â Â Â Â Â 1Â Â Â Â Â Â Â 0Â Â Â Â 0Â Â Â Â Â Â 00:01:18Â Â Â Â Â Â Â Â Â 0
We see above the BGP neighborship comes up as we configure the particular static routes.