Monday, September 26, 2022
HomeNetworkingnetlab VXLAN Bridging Instance « ipSpace.internet weblog

netlab VXLAN Bridging Instance « ipSpace.internet weblog


netlab launch 1.3 launched help for VXLAN transport with static ingress replication. Time to test how straightforward it’s to switch a VLAN trunk with VXLAN transport. We’ll use the lab topology from the VLAN trunking instance, change the VLAN trunk between S1 and S2 with an IP underlay community, and transport Ethernet frames throughout that community with VXLAN.

Lab topology

We nonetheless must outline the VLANs; we’ll set VLAN mode to bridge as we don’t wish to do any routing between VLANs.

Defining VLANs

vlans:
  purple:
    mode: bridge
  blue:
    mode: bridge

Subsequent: nodes and hyperlinks. The one distinction from the VLAN trunking topology is the final hyperlink: a point-to-point IP hyperlink between S1 and S2.

Defining nodes and hyperlinks

nodes: [ h1, h2, h3, h4, s1, s2 ]

hyperlinks:
- h1:
  s1:
    vlan.entry: purple
- h2:
  s2:
    vlan.entry: purple
- h3:
  s1:
    vlan.entry: blue
- h4:
  s2:
    vlan.entry: blue
- s1:
  s2:

Lastly a contact of magic. We’ll deploy VLAN, VXLAN and OSPF configuration modules on the switches – and that’s it.

Defining system teams

teams:
  hosts:
    members: [ h1, h2, h3, h4 ]
    system: linux
  switches:
    members: [ s1,s2 ]
    module: [ vlan,vxlan,ospf ]

Behind the scenes:

  • OSPF configuration module begins OSPF routing course of on each switches, enabling IP connectivity between their loopback interfaces (that are then used as VXLAN VTEPs).
  • VLAN configuration module creates VLAN knowledge buildings and figures out that S1 and S2 want purple and blue VLANs primarily based on the VLAN entry interfaces.
  • By default, the VXLAN configuration module transports all native VLANs throughout the underlay community. You’ll be able to change that habits with vxlan.vlans checklist, and lengthen solely a few of the VLANs throughout the underlay community.
  • VXLAN configuration module robotically builds per-VLAN ingress replication lists for each node utilizing vxlan module primarily based on which different nodes use the identical VLAN. You’ll be able to even outline a number of VXLAN bridging domains.

Right here’s a pattern Arista EOS configuration generated in the course of the netlab preliminary course of:

Arista cEOS VXLAN bridging configuration

hostname s1
!
spanning-tree mode mstp
!
vlan 1000
   identify purple
!
vlan 1001
   identify blue
!
interface Ethernet1
   switchport entry vlan 1000
!
interface Ethernet2
   switchport entry vlan 1001
!
interface Ethernet3
   description s1 -> s2
   no switchport
   ip handle 10.1.0.1/30
   ip ospf community point-to-point
   ip ospf space 0.0.0.0
!
interface Loopback0
   ip handle 10.0.0.5/32
   ip ospf space 0.0.0.0
!
interface Vlan1000
   description VLAN purple (1000) -> [h1,h2,s2]
!
interface Vlan1001
   description VLAN blue (1001) -> [h3,h4,s2]
!
interface Vxlan1
   vxlan source-interface Loopback0
   vxlan udp-port 4789
   vxlan vlan 1000 vni 101000
   vxlan vlan 1001 vni 101001
   vxlan vlan 1000 flood vtep 10.0.0.6
   vxlan vlan 1001 flood vtep 10.0.0.6
!
ip routing
!
router ospf 1
   router-id 10.0.0.5
   max-lsa 12000
!
finish

Need to run this lab by yourself, or attempt it out with completely different gadgets? No drawback:

RELATED ARTICLES

LEAVE A REPLY

Please enter your comment!
Please enter your name here

- Advertisment -
Google search engine

Most Popular

Recent Comments